Data Processing Delays - New Connects, Mover and Batch
Resolved
This incident has been resolved.
Posted Dec 01, 2023 - 19:04 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 30, 2023 - 14:06 EST
Identified
The issue has been identified and a fix is being implemented.
Our vendor is still working on implementing a fix.
Posted Nov 30, 2023 - 13:15 EST
Investigating
Due to a fiber cut in the main internet communication system servicing our Data Centers, we are experiencing unexpected delays in our operations. This has impacted not only our New Connects and Mover products but also other services that rely on timely data processing and delivery.

Despite our best efforts to reallocate resources and mitigate these delays, some services may still experience disruptions.

We understand the inconvenience this may cause and want to assure you that our team is working tirelessly with carrier support to resolve this issue at the earliest.
Posted Nov 29, 2023 - 15:41 EST
This incident affected: First Party Enrichment & Monitoring (First Party Enrichment & Monitoring: Batch) and Data Licensing & Syndication.