Multiple services outage

Resolved

All services are running normally.
Posted Oct 20, 2025 - 22:02 EDT

Update

All services are expected to be at 100% within the next 20 minutes.
Posted Oct 20, 2025 - 20:28 EDT

Update

AWS indicates most services are operating normally. We are continuing to monitor the situation and progress. We will update on the status and ETA of Activate files as soon as possible.
Posted Oct 20, 2025 - 17:12 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 17:12 EDT

Update

AWS capacity appears to have been improved. Activate files are processing and, if they continue to run, we expect they will be delivered in the next 2 - 3 hours.
Posted Oct 20, 2025 - 16:43 EDT

Update

AWS services continue to recover. Create and Audit API should be fully functional within the next 15 minutes. Activate files are expected to be delivered some time after 12 PM EST.
Posted Oct 20, 2025 - 15:34 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 14:00 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 14:00 EDT

Update

AWS services continue to recover. Activate files are expected to be delivered as soon as possible.
Posted Oct 20, 2025 - 13:54 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:09 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 09:25 EDT

Update

AWS services continue to recover. Activate files are expected to be delivered some time after 12 PM EST.
Posted Oct 20, 2025 - 09:13 EDT

Monitoring

AWS indicates most services are operating normally. We are continuing to monitor the situation and progress. We will update on the status and ETA of Activate files as soon as possible.
Posted Oct 20, 2025 - 07:03 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 06:50 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 06:50 EDT

Investigating

Due to a major AWS outage, several of our services are delayed or performing in a degraded state. We expect the issue to be fully resolved by 9 AM EST. Activate files will likely be delayed past 9 AM.
Posted Oct 20, 2025 - 06:50 EDT
This incident affected: First Party Enrichment & Monitoring (First Party Enrichment & Monitoring: Activate).